martedì 18 dicembre 2007

Pesi, multipli e arrotondamento?!

Abbiamo parlato di arrotondamento in Excel.


Esistono altre 3 funzioni che arrotondano, in un modo po' particolare. Sono piuttosto difficili da capire, ma cercherò di spiegarmi. Stiamo parlando di ARROTONDA.MULTIPLO, ARROTONDA.ECCESSO, ARROTONDA.DIFETTO.
ARROTONDA.MULTIPLO ha due argomenti: il numero da arrotondare e il multiplo. La funzione infatti restituisce un numero arrotondato al multiplo desiderato. Facciamo un esempio:
In A1 scrivi: 10


In B1 scrivi: =ARROTONDA.MULTIPLO(A1;3)

Il risultato sarà 9 (infatti 3 è un multiplo di 9). Se invece in A1 scrivi: 10,5

il risultato in B1 sarà 12.

E come? 12??! Eh già, perché la regola è questa: ARROTONDA.MULTIPLO arrotonda il valore assoluto del numero per eccesso qualora il resto della divisione di num per multiplo sia maggiore o uguale alla metà del valore di multiplo.
Mmm... mi sa che ora è meno chiaro di prima :-)

Cerchiamo di capire. Num / multiplo = 3 con resto 1,5 (infatti num=10,5 e multiplo = 3, quindi abbiamo 10,5/3). Dato che il resto 1,5 è maggiore o uguale alla metà del multiplo (3), si arrotonda per eccesso. E quindi... da 9 si passa a 12. Perciò se abbiamo 10,4 in A1, in B1 otterremo 9 (infatti il resto è 1,4 che non è maggiore o uguale alla metà del multiplo (cioè 3/2=1,5)
Proviamo un po' a fare un esempio concreto. Immaginate di avere numeri che vanno arrotondati all'euro, per esempio la retribuzione netta nella busta paga. Se il numero in A1 fosse 1.102,93 potrei scrivere in B1

=ARROTONDA.MULTIPLO(A1;1) ottenendo 1.103,00
Lo so, perché non usare ARROTONDA e basta? E' vero, ottengo lo stesso risultato facendo=ARROTONDA(A1;0).

Immagina però di dover arrotondare ai 10 euro, per esempio. Basterà scrivere in B1
=ARROTONDA.MULTIPLO(A1;10)

e così otterrò 1.100,00 (se vi ricordate quando c'erano le lire, si arrotondava alle 100 lire, talvolta alle mille...)
Ancora un esempio? Se siete arrivati fin qui... Immagina di avere un articolo il cui prezzo è espresso in dollari e devo ottenere il corrispettivo in euro. ora, supponi che il prezzo convertito in euro sia: 10,1256.
essuno potrebbe pagarlo... non abbiamo monetine così piccole! Prciò la soluzione più semplice è arrotondare a due decimali. n A1 scrivi: 10,1256 e in B1 scrivi

=ARROTONDA(A1;2)

così il prezzo diventa 10,13. ottimo, i centesimi ora li abbiamo. ma non è un po' complicato poi dare il resto? e se riuscissimo ad arrotondare in modo da avere un numero divisibile per 5 centesimi? tipo 10,10 oppure 10,15?
Ebene, ecco che viene utile ARROTONDA.MULTIPLO. In B1 scrivi
=ARROTONDA.MULTIPLO(A1;0,05)

il risultato sarà 10,15 quindi bastano i 5 centesimi. Se uso ARROTONDA.ECCESSO avrò l'arrotondamento sempre per eccesso e con ARROTONDA.DIFETTO l'arrotondamento sarà sempre per difetto. Interessante... e secondo te i prezzi "effetto-euro" hanno usato ARROTONDA.DIFETTO, ARROTONDA.ECCESSO oppure ARROTONDA.MULTIPLO?

Buon lavoro!
PS ARROTONDA.MULTIPLO si trova in Excel2007... ;-)

2 commenti:

Antonio ha detto...

A voi di Didalgo, un caro augurio di Buon Natale e prospero Anno Nuovo! Antonio

emanuele ha detto...

Grazie Antonio! Auguri a te e a a tutti i nostri fedelissimi lettori :-))